Pi PICO VCP & Message port - interesting development ?

Support for Arduino in combination with Air Manager and Air Player

Moderators: Ralph, russ

Post Reply
Message
Author
User avatar
jph
Posts: 2063
Joined: Fri Apr 10, 2020 12:50 pm
Location: Somewhere over the rainbow..

Pi PICO VCP & Message port - interesting development ?

#1 Post by jph »

@Corjan
Please can you assist with this one.
I have never been able to get any of the newer processors with VCP to work with message port - until today - .It was an accident how I discovered this but this is what happens.

When the amazing Pico or indeed STM32 and Nucleo boards or any of the latest boards with USB VCP - have been programmed with the mp lib then absolutely nothing is seen at all in AM, it will just sit there for ever - this is after adding the device port of course.

However, before opening AM, if I go to ANY terminal program, Putty, Hyperterminal etc etc, even the Arduino IDE Terminal window and simply connect to the com port - you don't have to type anything at all - just open a session and then close it, nothing more. Then open AM and 3 seconds later the device shows perfectly in AM and works absolutely flawlessly afterwards,. I can close and restart AM with no issues and have more or less instant mp device connection on startup, until the usb device is reset and then it needs 'waking ' again.

Help please :? :) ?

Once connected they work absolutely perfectly.
It would be really appreciated.
Joe
“Everything in moderation, including moderation.”
“Experience is merely the name men gave to their mistakes.”
Joe (CISSP) -IT security consultant

Post Reply