Image file AirPlayer with working autostart

Support for Air Player desktop on ARM devices, like the Raspberry Pi.

Moderators: Ralph, russ

Post Reply
Message
Author
ftnet305
Posts: 4
Joined: Fri Mar 18, 2022 10:58 am

Image file AirPlayer with working autostart

#1 Post by ftnet305 »

Hello everyone,

I am having such a hard time to set up autostart with RPi4B. After 3 days of reading all these posts and having to learn basic Linux commands makes me unhappy. The installation folder is a nightmare itself. There are spaces but I had to figure out that a space means a "\" in that weird language. Command cd works sometimes and other times only cd /... works. Then autostart files show up in the folder structure but are actually not there if I try to change these via the terminal. Having to figure out what to put into which folder is an entire mess. I am not a programmer and am sick of trial and error. I only want a working RPi in order to setup my simulator. Before AirPlayer ARM came there was AirPlayer for mini computers which was plug and play. It was wonderful! Now it cannot even be downloaded any more and my money spent for it is just gone. So at least SimInnovations should upload an image file with everything included (OS plus AP with working autostart!!!) or sell ready to use SD cards. Maybe they never will. And no, the setup will not enable autostart for whatever reason also I could try to install it 5 more times hitting "yes" to enable autostart....

So I kindly ask the community:

If anyone could be so kind to upload a complete image for the RPI 4 with a vanilla OS plus a working autostart AirPlayer would be awesome. It does not matter if the OS is 32 or 64 bit. Only autostart shall work.

Yours, Michael

User avatar
Ralph
Posts: 6607
Joined: Tue Oct 27, 2015 7:02 pm
Location: De Steeg
Contact:

Re: Image file AirPlayer with working autostart

#2 Post by Ralph »

That would only be if you use a different path. If you follow the instructions of the wiki then you only have to type in what it says. It also has autostart (if you select yes during the installation!), so you don't have to do any manual configurations.

ftnet305
Posts: 4
Joined: Fri Mar 18, 2022 10:58 am

Re: Image file AirPlayer with working autostart

#3 Post by ftnet305 »

These "instructions" are useless. It begins with
2. Unzip the downloaded Air Player zip file somewhere on your Linux system

Alright. The system suggests to unzip into the .tmp folder. Is this correct? Anytime I look into .tmp after a reboot the stuff is gone. So is this a problem? Where should I put it? I put it into my pi folder now.

3. Run the included Linux setup as root. This will install the required libraries.

What does "run as root" mean? Run it from /pi? Do some fancy sudo stuff? What am I supposed to do? I ran it from /pi and was able to install something with the command
sudo sh ./setup.sh
At the end of the setup it asks me if I want that autostart feature. You bet I want! So I hit "y" and it shows something like saved to .config/autostart
Looking into this file it proves to be just empty!

So I put this into this file (whatever this might do!):
@lxpanel --profile LXDE-pi
@pcmanfm --desktop --profile LXDE-pi
@xscreensaver -no-splash
@/home/pi/Air\Player\4.2\Home\Use/Bootloader

So did I spell these magic spaces correct? The folder name is "Air Player 4.2 Home Use". It took me hours to find out that spaces mean "\" for gods sake! Why they do not name it "airplayer"!!!
I can start the program with the command .bootloader but autostart will not work. Whatever I do and which folders I change. I end up flashing a new SD card just to find myself lost in space again. So instead of writing all this down, I would appreciate a plain vanilla image file to flash and rest in peace with whatever Linux is all about. If anybody wants to help please upload an image. Thanks

ftnet305
Posts: 4
Joined: Fri Mar 18, 2022 10:58 am

Re: Image file AirPlayer with working autostart

#4 Post by ftnet305 »

It´s day 5 since trying to get autostart to work. I finally achieved it by not using 64-bit but 32-bit OS and AirPlayer-Software. My first attempt with 32-bit did not suceed. Yet I think I found the reason for this but will not try again just for proving it. When the 32-bit software of AirPlayer is installed, it asks if autostart shall be enabled. The first time I hit "y" (lower case) and it did not work. At the second installation I pressed "Y" (higher case) and it worked out of the box. I hope anybody struggling with this founds that hint useful. I am so glad not having to dig into Linux any further. Still wondering why 64-bit caused so many issues but may it be as it is.

User avatar
jph
Posts: 2042
Joined: Fri Apr 10, 2020 12:50 pm
Location: Somewhere over the rainbow..

Re: Image file AirPlayer with working autostart

#5 Post by jph »

To use linux you have to be a drug crazed hippy with a chin beard and a fascination for foot ulcers, garden gnomes and field mice ;)
“Everything in moderation, including moderation.”
“Experience is merely the name men gave to their mistakes.”
Joe (CISSP) -IT security consultant

nnyerges
Posts: 25
Joined: Sat Jun 18, 2022 6:28 pm

Re: Image file AirPlayer with working autostart

#6 Post by nnyerges »

ftnet305 wrote: Sat Aug 06, 2022 10:35 am It´s day 5 since trying to get autostart to work. I finally achieved it by not using 64-bit but 32-bit OS and AirPlayer-Software. My first attempt with 32-bit did not suceed. Yet I think I found the reason for this but will not try again just for proving it. When the 32-bit software of AirPlayer is installed, it asks if autostart shall be enabled. The first time I hit "y" (lower case) and it did not work. At the second installation I pressed "Y" (higher case) and it worked out of the box. I hope anybody struggling with this founds that hint useful. I am so glad not having to dig into Linux any further. Still wondering why 64-bit caused so many issues but may it be as it is.
Im following your post to see if you get any soutions. Please visit my post https://siminnovations.com/forums/viewt ... 800#p47800 to follow my. Have a nice day

Post Reply