X-plane plugin incompatible with steam libcurl on linux

Discuss suspected bugs with other users and Sim Innovations Staff

Moderators: Ralph, russ

Post Reply
Message
Author
coljac
Posts: 2
Joined: Thu Nov 25, 2021 1:41 am

X-plane plugin incompatible with steam libcurl on linux

#1 Post by coljac »

Hi there,

I've noticed some previous threads about libcurl, and that the plugin is now compiled against libcurl 4. However, even though I have libcurl 4 installed on my system, the Air Manager plugin fails to initialize; it cannot load the libcurl.so.4 successfully. There is something about the libcurl that ships with steam that doesn't work with the Air Plugin.

Code: Select all

dlerror:/home/coljac/.local/share/Steam/ubuntu12_32/steam-runtime/pinned_libs_64/libcurl.so.4: version `CURL_OPENSSL_4' not found (required by /ssd/steam/steamapps/common/X-Plane 11/Resources/plugins/Air Plugin/64/lin.xpl)
I've gathered that between libcurl 4.2 and 4.4 there's a change in the CURL_OPENSSL dependency.
This does work:

Code: Select all

cd /home/coljac/.local/share/Steam/ubuntu12_32/steam-runtime/pinned_libs_64/
# libcurl.so.4 is symlinked to /home/coljac/.local/share/Steam/ubuntu12_32/steam-runtime/usr/lib/x86_64-linux-gnu/libcurl.so.4.2.0
ln -s /home/coljac/.local/share/Steam/ubuntu12_32/steam-runtime/usr/lib/x86_64-linux-gnu/libcurl.so.4.2.0 oldlibcurl
rm libcurl.so.4
ln -s /usr/lib/x86_64-linux-gnu/libcurl.so.4 libcurl.so.4
However, after I make this change, X-Plane crashes every time I quit. There's nothing in Log.txt apart from "--=={This application has crashed!}==--" but I have verified this is the reason. This isn't entirely optimal! Is there a way to rebuild the plugin to avoid this issue? Perhaps against an older version of libcurl4 (i.e. 4.2?).

I'm using Ubuntu 20.04, with these packages installed:

Code: Select all

libcurl4-openssl-dev/focal-updates,focal-security,now 7.68.0-1ubuntu2.7 amd64 
libcurl4/focal-updates,focal-security,now 7.68.0-1ubuntu2.7 amd64

blue67
Posts: 1
Joined: Tue Feb 08, 2022 10:26 pm

Re: X-plane plugin incompatible with steam libcurl on linux

#2 Post by blue67 »

Hmm. This must be the reason the plugin is failing to load for me. I found the line in log.txt, followed all the symlinks in steam, but haven't tried replacing the libcurl library yet. Did you find a fix?

coljac
Posts: 2
Joined: Thu Nov 25, 2021 1:41 am

Re: X-plane plugin incompatible with steam libcurl on linux

#3 Post by coljac »

blue67 wrote: Tue Feb 08, 2022 10:28 pm Hmm. This must be the reason the plugin is failing to load for me. I found the line in log.txt, followed all the symlinks in steam, but haven't tried replacing the libcurl library yet. Did you find a fix?
I haven't - if I want to use this plugin, I get a crash on exit of X-Plane. However, it does work when I'm flying.

User avatar
Ralph
Posts: 6656
Joined: Tue Oct 27, 2015 7:02 pm
Location: De Steeg
Contact:

Re: X-plane plugin incompatible with steam libcurl on linux

#4 Post by Ralph »

Libcurl is always bothering us. Ubuntu removed a certain version of libcurl in a certain Ubuntu version, and then brought it back in the next version of Ubuntu. That's at least what I was told. Although that probably does explain the crash.

I will discuss it with our Linux guy later this week.

Post Reply