MessagePort USB problem

Working on a instrument project or just finished a project? Show it to others!

Moderators: Ralph, russ

Message
Author
Detlef
Posts: 79
Joined: Mon Nov 16, 2020 9:43 am
Location: Bavaria

Re: MessagePort USB problem

#21 Post by Detlef » Mon Apr 05, 2021 4:34 pm

jph wrote:
Mon Apr 05, 2021 10:21 am
Hi again Detlef,
We talked about a way of checking for established connection on message port -
This should be interesting to you -
https://siminnovations.com/wiki/index.p ... ssage_port
Check out the hw_connected
I hadn't noticed this before. :roll: Might be just what you wanted ?
Joe
Hi Joe,
yes I am aware of the hw_connected() function. It doesn't help if the thing won't connect :)
Today everything was fine. I used a different USB port on the PC

Thank you
Detlef

Detlef
Posts: 79
Joined: Mon Nov 16, 2020 9:43 am
Location: Bavaria

Re: MessagePort USB problem

#22 Post by Detlef » Mon Apr 05, 2021 5:03 pm

jph wrote:
Mon Apr 05, 2021 10:10 am
Hi Detlef, firstly, AMAZING work, it looks absolutely superb. I am well impressed :D
Really interesting that another USB port seems to work - albeit on an 'extender'
Can I just please clarify what you mean by 'extender' ?
Do you mean a USB HUB ? - like a 4 port hub etc - or, do you mean an amplified / repeater single USB cable ?
If it is a 'hub' . is it self powered or does it have an external PSU to the HUB ?
I think you might be getting to the bottom of your issues. ;)

Is it possible to post larger format images ? - I would just love to see the panel work etc.
I wouldn't worry in the slightest about 'original' - read 'trademarked' Arduinos as there is no difference at the end of the day, the 'trademarked' ones are overpriced and overhyped. It is a fully open source project. The only thing that the arduino 'store' sells that is really different is the trademark and rip you off for it. Stick with the non trademarked units :geek: You will have no issue 99% of the time. A said, the ONLY time I have had an Arduino issue (that wasn't my own stupid fault :D ) was with a 'trade marked' UNO.

Would love to see more details on the buttons used around the paperwhite units
Classic work..
Joe
Joe,

sorry I had not seen this post before. I had a dealer configure my PC, if I see it right this is the USB card:
1060439, Controller PCIe 4x USB 3.0 NEC.

Thank you for your praise :) I was actually thinking about explaining my setup and work. But that takes quite some time for me to do, find camera, microphone, app. I never published a video. So for now I want to concentrate to get it working for good. Regarding the pictures: the forum interface keeps telling me the pictures are too big if I try bigger ones. I'll do more later, I promise. What helped me a lot is the screw shield for the Arduino Mega by www.electronics-salon.com. I got it from China directly, no problems, good printings on the screw pads, good screws... I have it without encasing. I guess, those components are used in some automation controls and such.

Detlef

User avatar
jph
Posts: 554
Joined: Fri Apr 10, 2020 12:50 pm
Location: A Brit exiled to Portugal

Re: MessagePort USB problem

#23 Post by jph » Tue Apr 06, 2021 5:54 am

Hi Detlef,
The USB Card will almost certainly deliver more power to the PCI port. I presume they are USB ports ?
If you used a USB 2 port it may be exceeding the max port power (curent). The PCIe cards tend to use a spare sata connector as power only to ensure adequate supply to each port.
I know you said you are using an external power supply, but it sounds strange. It may simply be that you have an issue with one of your mainboard USB ports ?. How long is the USB cable out of interest.

I would definitely love to more more about your unit as it looks like a work of art. I always use JPG images and on the rare occasion I have a size issue I just use PSP8 to resize them - or GIMP or whatever.
The boards for the mega with screw terminals are really neat. I think I have a few of the https://www.aliexpress.com/item/3282296 ... hweb201603_ type ones around. My bro Steve has used them to great success also.
Joe
“Everything in moderation, including moderation.”
“I am not young enough to know everything.”
“Experience is merely the name men gave to their mistakes.”
-- Oscar Wilde --
Joe (CISSP) -IT security consultant

Detlef
Posts: 79
Joined: Mon Nov 16, 2020 9:43 am
Location: Bavaria

Re: MessagePort USB problem

#24 Post by Detlef » Tue Apr 06, 2021 8:57 pm

Joe,

yes I meant USB ports. I'll keep an eye on this, today it did work fine. The USB cable is about 2 m (including an extension cable).

Detlef

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests