COPY / PASTE not removing highlighted text ?

Let Sim Innovations know about your Air Manager experience and let us know about your dream feature addition

Moderators: Ralph, russ

Message
Author
User avatar
Ralph
Posts: 5090
Joined: Tue Oct 27, 2015 7:02 pm
Location: De Steeg
Contact:

Re: COPY / PASTE not removing highlighted text ?

#11 Post by Ralph » Tue Apr 13, 2021 7:24 am

Aah now I see what you mean. I have never used the right click option :) I'll add it to the to-do list.

User avatar
jph
Posts: 655
Joined: Fri Apr 10, 2020 12:50 pm
Location: Portugal

Re: COPY / PASTE not removing highlighted text ?

#12 Post by jph » Tue Apr 13, 2021 7:28 am

Ralph wrote:
Tue Apr 13, 2021 7:24 am
Aah now I see what you mean. I have never used the right click option :) I'll add it to the to-do list.
Thanks Ralph, Just a note - I edited my last post to also say that the buttons you include in the API for cut / paste etc also do not work correctly (I presume they use the same code).
The right click option seems to be the almost universally accepted use if available.
Thanks again. :)
Joe
“Everything in moderation, including moderation.”
“Experience is merely the name men gave to their mistakes.”
Joe (CISSP) -IT security consultant

User avatar
Ralph
Posts: 5090
Joined: Tue Oct 27, 2015 7:02 pm
Location: De Steeg
Contact:

Re: COPY / PASTE not removing highlighted text ?

#13 Post by Ralph » Tue Apr 13, 2021 7:32 am

I'm not sure what you mean with buttons included in the API for cut and paste.

User avatar
jph
Posts: 655
Joined: Fri Apr 10, 2020 12:50 pm
Location: Portugal

Re: COPY / PASTE not removing highlighted text ?

#14 Post by jph » Tue Apr 13, 2021 7:46 am

Sling wrote:
Mon Apr 12, 2021 1:28 pm

I'm pretty sure I reported these issues a long while back. I have a list somewhere I'll see if i can dig it out if there is motivation to fix them. I was kinda waiting for 4.0 to release before mentioning them again. Some immediate ones come to mind.

The cursor placement after <CR> is particularly annoying. If i hit <CR> at the beginning of an indented row of code i expect this line to be moved down one and the cursor still sitting at the beginning of the row with a new blank row now one row above. If i hit it a few times I expect that many new lines but with the cursor in the same spot as i originally put it. It does some weird identing with the cursor position a code on the existing line and then you have to fix it up. Most annoying and very time consumming.

When you hit <CR> the rows above that point scroll up out of view a row at a time but only if there is code on that line. It works the opposite when the line is blank. Its more logical to move the rows down below the cursor position and it seems to be the convention also. Try it on row 1 and you don't see the new row. IMHO it should scroll the editor window down a row to show the new row above with the cursor sitting at the beginning of row 2.

The weird highlighting mentioned here. I find it highlights the text when i don't want it highlighted. Often when you click at the beginning of the row. In fact its not highlighted in the strict sense because if you hit delete it just removes a single character rather than everything highlighted. You generally have to click somewhere else and then highlight it by dragging across the text to get it truly highlighted.
Hi @Sling
I believe I completely agree with you on this - presuming I am understanding you correctly.
Please can you do a quick test in the Arduino IDE and see if it conforms to what you are saying - I believe it does. Then we are on the same page.
The Arduino IDE, to me, is virtually the same standard as all other editors I have used, and am used to.
If this is the case, then - again, I whole heartedly agree.
Joe
“Everything in moderation, including moderation.”
“Experience is merely the name men gave to their mistakes.”
Joe (CISSP) -IT security consultant

User avatar
jph
Posts: 655
Joined: Fri Apr 10, 2020 12:50 pm
Location: Portugal

Re: COPY / PASTE not removing highlighted text ?

#15 Post by jph » Tue Apr 13, 2021 7:49 am

Ralph wrote:
Tue Apr 13, 2021 7:32 am
I'm not sure what you mean with buttons included in the API for cut and paste.
@Ralph Hi again :D
Image1.jpg
“Everything in moderation, including moderation.”
“Experience is merely the name men gave to their mistakes.”
Joe (CISSP) -IT security consultant

User avatar
Ralph
Posts: 5090
Joined: Tue Oct 27, 2015 7:02 pm
Location: De Steeg
Contact:

Re: COPY / PASTE not removing highlighted text ?

#16 Post by Ralph » Tue Apr 13, 2021 9:10 am

Okay, now I understand :)

User avatar
jph
Posts: 655
Joined: Fri Apr 10, 2020 12:50 pm
Location: Portugal

Re: COPY / PASTE not removing highlighted text ?

#17 Post by jph » Tue Apr 13, 2021 10:00 am

Ralph wrote:
Tue Apr 13, 2021 9:10 am
Okay, now I understand :)
Praise be to the Ralph. :) :mrgreen:
What @Sling said is also spot on..

A 'Find - a ' 'Find and Replace', and 'Find and Replace All' are surely needed................. :shock:

It is a bleeding nightmare when you want to change the name of a function / call or whatever. - it would move the API to an new and more standardised level.
I bow oh wise one. -- my nurse told me I should.
Also, when you posted 'hello world' and then 'goodbye world' I couldn't help thinking of 'Dignitas'.... :o :shock: :lol: Nooooooooooooo... not yet.... :shock: :shock: :shock:
:roll:
“Everything in moderation, including moderation.”
“Experience is merely the name men gave to their mistakes.”
Joe (CISSP) -IT security consultant

User avatar
Sling
Posts: 4436
Joined: Mon Sep 11, 2017 2:37 pm
Contact:

Re: COPY / PASTE not removing highlighted text ?

#18 Post by Sling » Sat May 01, 2021 11:40 pm

Something i missed. I've also added it to my post that lists the issues so they are all together.

When you paste something the editor window is scrolled to make the row with the pasted information as the top shown row. It should just stay as it is. i.e. no scrolling.

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests