Are the updates required to keep AM functional?

Peer support for Air Manager desktop users

Moderators: Ralph, russ

Post Reply
Message
Author
maxten74
Posts: 9
Joined: Thu Jul 23, 2020 11:22 pm

Are the updates required to keep AM functional?

#1 Post by maxten74 » Sun May 02, 2021 4:33 pm

Hello,

Simple question from a non tekkie. Are the updates required to keep AM functional? I am using x-plane 5.x(whatever). I think I'm using AM 3.4 because I never updated to 3.7 due to the issues I had when I updated to 3.4. Both x-plane and AM are doing exactly what I need them to do right now and I'm a big fan of "if it ain't broke, don't fix it." Will not updating cause me issues with my current version down the road or will it prevent me from using newer functions in AM and/or x-plane? Thanks for your patience and any assistance you can provide.

User avatar
jph
Posts: 661
Joined: Fri Apr 10, 2020 12:50 pm
Location: Portugal

Re: Are the updates required to keep AM functional?

#2 Post by jph » Mon May 03, 2021 11:07 am

maxten74 wrote:
Sun May 02, 2021 4:33 pm
Hello,

Simple question from a non tekkie. Are the updates required to keep AM functional? I am using x-plane 5.x(whatever). I think I'm using AM 3.4 because I never updated to 3.7 due to the issues I had when I updated to 3.4. Both x-plane and AM are doing exactly what I need them to do right now and I'm a big fan of "if it ain't broke, don't fix it." Will not updating cause me issues with my current version down the road or will it prevent me from using newer functions in AM and/or x-plane? Thanks for your patience and any assistance you can provide.
If what you are doing and what you require and expect are suitable, and you change nothing, then absolutely yes - stick to what you have - 'if it ain't broke, don't fix it!'
That's it really..
HOWEVER, if you come across something that is definitely an issue that is not your fault, then maybe think about an upgrade. From what you say, you are nowhere near that yet.
Enjoy.
“Everything in moderation, including moderation.”
“Experience is merely the name men gave to their mistakes.”
Joe (CISSP) -IT security consultant

maxten74
Posts: 9
Joined: Thu Jul 23, 2020 11:22 pm

Re: Are the updates required to keep AM functional?

#3 Post by maxten74 » Mon May 03, 2021 8:39 pm

Thanks for the response. I'm so non technical that the add on's and plugins that are recommended to make x-plane more realistic give me nightmares. I don't have the knowledge or the skills to adjust code, reorder scenery, etc to take advantage of this stuff and messing with AM's technical stuff puts me in the same boat. I'll keep 3.4 until something makes it unusable and I'm forced to update to 4.whatever.

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests