KnobXP not loading on Linux

Support for KnobXP, share your experience and KnobXP modes.

Moderators: Ralph, russ

Post Reply
Message
Author
simgene
Posts: 8
Joined: Thu Oct 07, 2021 9:02 pm

KnobXP not loading on Linux

#1 Post by simgene » Fri Oct 08, 2021 2:54 am

Hi all,

Got my Knobster from xforcepc yesterday, and tried immediately to set it up.

Downloaded the plugin from the wiki.

I cannot get it to load. I have unzipped it in /home/gene/X-Plane 11/Resources/plugins/, restarted. Not matter what I cannot get it to show in x-plane. Note that I'm not interested in VR, and I'm not using Air Manager. I'm just using regular X-plane, and am looking forward to setting frequencies with the Knobster.

I think I have a clue in Log.txt, but not sure best way to fix.

Log.txt without KnobXP (Notice, no errors.)

Fetching plugins for /home/gene/X-Plane 11/Resources/plugins

Loaded: /home/gene/X-Plane 11/Resources/plugins/PluginAdmin/64/lin.xpl (xpsdk.examples.pluginadmin).

Loaded: /home/gene/X-Plane 11/Resources/plugins/PilotEdge/64/lin.xpl (com.pilotedge.plugin.xplane).

Log.txt with KnobXP (Notice, shows an error.)

Fetching plugins for /home/gene/X-Plane 11/Resources/plugins

Loaded: /home/gene/X-Plane 11/Resources/plugins/PluginAdmin/64/lin.xpl (xpsdk.examples.pluginadmin).

dlerror:libGLEW.so.2.0: cannot open shared object file: No such file or directory
Loaded: /home/gene/X-Plane 11/Resources/plugins/PilotEdge/64/lin.xpl (com.pilotedge.plugin.xplane).

I'm assuming that missing libGLEW.so.2.0 is the problem.

$ lsb_release -a
Description: Ubuntu 20.04.2 LTS
Release: 20.04

Here are my options for libglew on this Linux system.

$ sudo apt search libglew
glew-utils/focal 2.1.0-4 amd64
OpenGL Extension Wrangler - utilities

libglew-dev/focal 2.1.0-4 amd64
OpenGL Extension Wrangler - development environment

libglew2.1/focal 2.1.0-4 amd64
OpenGL Extension Wrangler - runtime environment

libglewmx-dev/focal 1.13.0-4ubuntu3 amd64
OpenGL Extension Wrangler MX - development environment

libglewmx1.13/focal 1.13.0-4ubuntu3 amd64
OpenGL Extension Wrangler (Multiple Rendering Contexts)



I tried installing libglew2.1/focal 2.1.0-4 amd64
OpenGL Extension Wrangler - runtime environment

No luck. Got the same error again in Log.txt, so it seems KnobXP plugin really wants 2.0.

A quick look shows that libglew2.0 is not available for my Ubuntu system (without me messing with apt.) My system really wants 2.1. Also, a quick search of installed apps shows no version of libglew is currently installed. Looks like it's not there by default.

$ ./X-Plane-x86_64 --version
X-Plane 11.55r2

$ dmesg
[27256.565290] usb 5-4: USB disconnect, device number 5
[27257.085740] usb 5-4: new full-speed USB device number 6 using xhci_hcd
[27257.263768] usb 5-4: New USB device found, idVendor=16d0, idProduct=0e8a, bcdDevice= 1.00
[27257.263775] usb 5-4: New USB device strings: Mfr=1, Product=2, SerialNumber=220
[27257.263778] usb 5-4: Product: Knobster
[27257.263780] usb 5-4: Manufacturer: Sim Innovations B.V.
[27257.263781] usb 5-4: SerialNumber: 75932333135351511210

$ lsusb
Bus 006 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 005 Device 006: ID 16d0:0e8a MCS Knobster
Bus 005 Device 004: ID 06a3:0763 Saitek PLC Pro Flight Rudder Pedals
Bus 001 Device 003: ID 046d:c05a Logitech, Inc. M90/M100 Optical Mouse
Bus 001 Device 002: ID 068e:00ff CH Products, Inc. Flight Sim Yoke

I hope someone can help. But, if not, and I sort this out, I'll update this post.

simgene
Posts: 8
Joined: Thu Oct 07, 2021 9:02 pm

Re: KnobXP not loading on Linux

#2 Post by simgene » Fri Oct 08, 2021 3:26 pm

I tried hacking a bit

I installed libGLEW.so.2.1, then created an alias to it called libGLEW.so.2.0. Clearly this is a hack, and I'm just trying to figure this out by trying things.

The new error in the Log.txt is

dlerror:/home/gene/X-Plane 11/Resources/plugins/KnobXP/64/lin.xpl: undefined symbol: hid_init

This tells me that KnobXP found the alias lib, but now another problem is found.

At this point, I'm going to need some help. I'm not sure what else to try. Am I running an unsupported version of Ubuntu/Linux? Is there another version of KnobXP that will work for this setup?

Thank you ahead of time for any help you can give.

User avatar
Corjan
Posts: 2505
Joined: Thu Nov 19, 2015 9:04 am

Re: KnobXP not loading on Linux

#3 Post by Corjan » Wed Oct 13, 2021 12:51 pm

Hi,


First off, sorry for my late response.

Seems like Ubuntu 20.04 ships with a newer version of GLEW. I am still using Ubuntu 18.04 LTS.
There is always hassle with libraries on Linux unfortunately.


The hid_init error is my doing. It should be fixed now, would you mind downloading a new version on the wiki and test that one?

Corjan

simgene
Posts: 8
Joined: Thu Oct 07, 2021 9:02 pm

Re: KnobXP not loading on Linux

#4 Post by simgene » Thu Oct 14, 2021 7:12 pm

Hi Corjan,

Thanks for the help. First no need to apologize. I'd like to get this working, but I really don't mind working with you to get it going. In fact, I wouldn't mind being a tester in the future for you, if that would help. But, ultimate goal, I really do want to get this expensive, but potentially really cool and worth it Knobster going. Also, I'm on the board of a flying club/school, and once I get this going and learn it, I'll let all our students with sims know about it.

Now for testing report

I downloaded the new KnobXP zip. (http://siminnovations.com/wiki/index.php?title=KnobXP)

With stock libGLEW.so.2.1 on the system, the plugin doesn't load
Fetching plugins for /home/gene/X-Plane 11/Resources/plugins

Loaded: /home/gene/X-Plane 11/Resources/plugins/PluginAdmin/64/lin.xpl (xpsdk.examples.pluginadmin).

dlerror:libGLEW.so.2.0: cannot open shared object file: No such file or directory
dlerror:libGLEW.so.2.0: cannot open shared object file: No such file or directory
Loaded: /home/gene/X-Plane 11/Resources/plugins/PilotEdge/64/lin.xpl (com.pilotedge.plugin.xplane).
I put my hacking symlink back in
sudo ln -s libGLEW.so.2.1.0 libGLEW.so.2.0
Some progress - the plugin loads x-plane, I see the setting page, and it's in the plugin menu, but in both settings and the chooser window it says "Knobster not connected"
knobxp.jpg
A;though progress, it still show the hid_init error in Log.txt
Fetching plugins for /home/gene/X-Plane 11/Resources/plugins

Loaded: /home/gene/X-Plane 11/Resources/plugins/PluginAdmin/64/lin.xpl (xpsdk.examples.pluginadmin).

Loaded: /home/gene/X-Plane 11/Resources/plugins/KnobXP/64/lin.xpl (com.siminnovations.knobxp).

dlerror:/home/gene/X-Plane 11/Resources/plugins/KnobXP.orig/64/lin.xpl: undefined symbol: hid_init
Loaded: /home/gene/X-Plane 11/Resources/plugins/PilotEdge/64/lin.xpl (com.pilotedge.plugin.xplane).
I would like to keep 20.04, but if you aren't able to get it working, I will consider downgrading to 18.04, and testing.

More data - syslog shows Knobster seems to mount on USB ok
Oct 14 11:59:27 ifr-sim kernel: [ 2200.212370] usb 5-4: USB disconnect, device number 29
Oct 14 11:59:39 ifr-sim kernel: [ 2212.184579] usb 5-4: new full-speed USB device number 30 using xhci_hcd
Oct 14 11:59:39 ifr-sim kernel: [ 2212.358400] usb 5-4: New USB device found, idVendor=16d0, idProduct=0e8a, bcdDevice= 1.00
Oct 14 11:59:39 ifr-sim kernel: [ 2212.358407] usb 5-4: New USB device strings: Mfr=1, Product=2, SerialNumber=220
Oct 14 11:59:39 ifr-sim kernel: [ 2212.358410] usb 5-4: Product: Knobster
Oct 14 11:59:39 ifr-sim kernel: [ 2212.358412] usb 5-4: Manufacturer: Sim Innovations B.V.
Oct 14 11:59:39 ifr-sim kernel: [ 2212.358414] usb 5-4: SerialNumber: 75932333135351511210
Oct 14 11:59:39 ifr-sim mtp-probe: checking bus 5, device 30: "/sys/devices/pci0000:00/0000:00:08.1/0000:0b:00.3/usb5/5-4"
Oct 14 11:59:39 ifr-sim mtp-probe: bus: 5, device: 30 was not an MTP device
Oct 14 11:59:39 ifr-sim mtp-probe: checking bus 5, device 30: "/sys/devices/pci0000:00/0000:00:08.1/0000:0b:00.3/usb5/5-4"
Oct 14 11:59:39 ifr-sim mtp-probe: bus: 5, device: 30 was not an MTP device

simgene
Posts: 8
Joined: Thu Oct 07, 2021 9:02 pm

Re: KnobXP not loading on Linux

#5 Post by simgene » Sun Oct 17, 2021 3:59 pm

Hi Corjan,

I reinstalled my system with Ubuntu 18.04. I have working all except the Knob.

Now, however, Log.txt shows it loaded.
Loaded: /home/gene/X-Plane 11/Resources/plugins/KnobXP/64/lin.xpl (com.siminnovations.knobxp).
This was the case with Ubuntu 209.04 also, when hackishly created a simlink to libGLEW.2.1 (and used your updated plugin.)

But, now that I'm having the same problem with 18.04, with no hackish changes, I'm starting to wonder if the Knobster itself is defective.

Now, when I load x-plane, KnobXP loads, but the window says Knobster disconnected - see graphic above, it's the same as I saw on 20.04

Is there a way to test the Knobster?

/var/lib/syslog says this when I plugin the Knobster
Oct 17 08:45:13 gbc-sim-box kernel: [ 3650.511060] usb 5-3: new full-speed USB device number 9 using xhci_hcd
Oct 17 08:45:13 gbc-sim-box kernel: [ 3650.684240] usb 5-3: New USB device found, idVendor=16d0, idProduct=0e8a, bcdDevice= 1.00
Oct 17 08:45:13 gbc-sim-box kernel: [ 3650.684242] usb 5-3: New USB device strings: Mfr=1, Product=2, SerialNumber=220
Oct 17 08:45:13 gbc-sim-box kernel: [ 3650.684244] usb 5-3: Product: Knobster
Oct 17 08:45:13 gbc-sim-box kernel: [ 3650.684245] usb 5-3: Manufacturer: Sim Innovations B.V.
Oct 17 08:45:13 gbc-sim-box kernel: [ 3650.684246] usb 5-3: SerialNumber: 75932333135351511210
Oct 17 08:45:13 gbc-sim-box mtp-probe: checking bus 5, device 9: "/sys/devices/pci0000:00/0000:00:08.1/0000:0b:00.3/usb5/5-3"
Oct 17 08:45:13 gbc-sim-box mtp-probe: bus: 5, device: 9 was not an MTP device
Oct 17 08:45:13 gbc-sim-box upowerd[1198]: unhandled action 'bind' on /sys/devices/pci0000:00/0000:00:08.1/0000:0b:00.3/usb5/5-3
I'm not sure, but this looks like it might be the plugin when I run lsusb
Bus 005 Device 009: ID 16d0:0e8a MCS
I'm out of ideas now. Please help.

simgene
Posts: 8
Joined: Thu Oct 07, 2021 9:02 pm

Re: KnobXP not loading on Linux

#6 Post by simgene » Sun Oct 17, 2021 5:31 pm

Update. I was able to run a demo version of x-plane on my MacOS system with the Knobster and it worked. I can't use x-plane properly on this laptop, it's too slow. But it was good enough to test that the Knobster button is functional.

So, now the problem is on my Linux system. Is there another log file for KnobXP that you can recommend?

User avatar
Corjan
Posts: 2505
Joined: Thu Nov 19, 2015 9:04 am

Re: KnobXP not loading on Linux

#7 Post by Corjan » Mon Oct 18, 2021 10:47 am

Hi,


It might be a rule missing in Linux.

Would you mind unpacking the attachment, and running the following commands:
cp ./42-knobster.rules /etc/udev/rules.d/42-knobster.rules
udevadm control --reload-rules

42-knobster.7z
(230 Bytes) Downloaded 45 times
Sorry for the trouble, I just released KnobXP for Linux, and it seems there are still some issues there...
If you are up for it, we can make an appointment where I connect to your computer using Teamviewer and see if I can get it to work.


Corjan

simgene
Posts: 8
Joined: Thu Oct 07, 2021 9:02 pm

Re: KnobXP not loading on Linux

#8 Post by simgene » Mon Oct 18, 2021 2:26 pm

That was it!! It's now loading and functioning as expected

Thanks so much for the help.

For anyone reading here is what was done to resolve
1. Use Ubuntu 18.04
2. Install the rules provided above

simgene
Posts: 8
Joined: Thu Oct 07, 2021 9:02 pm

Re: KnobXP not loading on Linux

#9 Post by simgene » Sat Oct 23, 2021 3:39 pm

Was working, now x-plane won't start, after rebooting. Log.txt

--=={This application has crashed because of the plugin: KnobXP}==--

syslog

Oct 23 08:41:58 gbc-sim-box kernel: [ 662.641379] Main Thread[4134]: segfault at 0 ip 0000000000000000 sp 00007ffd09d8ba78 error 14 in X-Plane-x86_64[400000+1e69000]
Oct 23 08:41:58 gbc-sim-box kernel: [ 662.641402] Code: Bad RIP value.


What is weird is after installing 18.04, applying the dev rules, the Knobster was working. I rebooted my system to verify that would work, and now I get the segfault with the plugin installed. If I remove KnobXP plugin, x-plane starts. I downloaded the KnobXP plugin again, as a test, no change.

Perhaps something changed in the reboot. Can you help?

simgene
Posts: 8
Joined: Thu Oct 07, 2021 9:02 pm

Re: KnobXP not loading on Linux

#10 Post by simgene » Fri Nov 12, 2021 10:56 pm

I got it working for awhile, but today x-plane won't start

From Log.txt
--=={This application has crashed because of the plugin: KnobXP}==--

From syslog
Nov 12 14:47:22 sim-box kernel: [ 1483.242170] Main Thread[7744]: segfault at 0 ip 0000000000000000 sp 00007ffe4b453d08 error 14 in X-Plane-x86_64[400000+1e69000]
Nov 12 14:47:22 sim-box kernel: [ 1483.242188] Code: Unable to access opcode bytes at RIP 0xffffffffffffffd6.

Suggestion. The Knobser is expensive, can you open source the KnobXP, so bugs can be fixed for Linux?

I had it working for quite a few days, and now for no obvious reason, as I sit down to fly a few instrument approaches, I can't even start x-plane.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests