[solved] Strange potentiometer behaviour after AM 4.0 upgrade

Support for Arduino in combination with Air Manager and Air Player

Moderators: Ralph, russ

Message
Author
altack
Posts: 33
Joined: Mon Nov 21, 2016 1:13 pm

Re: Strange potentiometer behaviour after AM 4.0 upgrade

#31 Post by altack » Mon May 03, 2021 3:52 pm

JackZ wrote:
Mon May 03, 2021 1:57 pm
To be picky (you know me 8-) ), the compas rose should probably be mounted on a gimbal to stay horizontal during turns?
That’s the power of mind and a good immersion factor : you could swear the compass rose is pulling Gs during turns :lol:

As a matter of fact, Jacques, not until I actually built that wet compass did I really paid attention to the way FSX (or P3D) neatly simulated compass behavior !

I was amazed by the way the compass rose swung during acceleration at take-off (or deceleration during landings).

Also, and it reminds me flight training when I was a young and eager student pilot, when performing full circle turns at constant bank angle, you can see in the sim that the compass is « nervous » approaching north and « sluggish  » near south : As real as it gets !
I still need to perform this check in Australia to see it is reversed though ;)

JackZ
Posts: 1850
Joined: Mon Feb 22, 2016 1:02 pm

Re: Strange potentiometer behaviour after AM 4.0 upgrade

#32 Post by JackZ » Mon May 03, 2021 7:21 pm

Aha, the infamous ANDS & SAND: accelerate North, decelerate South!
I didn’t dare to offer to put into the casing a DOUBLE gimbal to emulate as well the acceleration factor, which I didn’t knew FSX emulated! :o
Very well done already!

Jacques
My YouTube Chanel on the A320 (Real SOPs by an Airline Pilot IRL):
https://www.youtube.com/playlist?list=P ... 0Q6SBASRqJ

altack
Posts: 33
Joined: Mon Nov 21, 2016 1:13 pm

Re: Strange potentiometer behaviour after AM 4.0 upgrade

#33 Post by altack » Thu May 06, 2021 6:11 am

Ralph wrote:
Sun May 02, 2021 1:33 pm
I'll see if I can remember to try a stepper on an Uno this week.
Hi Ralph,
Any update on your test ?

altack
Posts: 33
Joined: Mon Nov 21, 2016 1:13 pm

Re: Strange potentiometer behaviour after AM 4.0 upgrade

#34 Post by altack » Mon May 10, 2021 7:54 am

Hi Ralph and the Team,

Still looking forward to hearing from your stepper motor tests under the latest AM 4.0 release...
Should I open an other thread ?

Thank you in advance for your support
Francois

User avatar
Ralph
Posts: 5078
Joined: Tue Oct 27, 2015 7:02 pm
Location: De Steeg
Contact:

Re: Strange potentiometer behaviour after AM 4.0 upgrade

#35 Post by Ralph » Mon May 10, 2021 9:41 am

Didn't have time. Need to finish the administration very soon :(

altack
Posts: 33
Joined: Mon Nov 21, 2016 1:13 pm

Re: Strange potentiometer behaviour after AM 4.0 upgrade

#36 Post by altack » Sun May 16, 2021 9:49 pm

Hi everyone,
without more info on Stepper Motor actual useage under AM 4.0.1 I reverted back to AM 3.7.1 and, guess what, my Wet Compass is working again !
I'm still interested, though, on your feedback regarding this Arduino UNO/Stepper Motor DIR & STEP commands unsatisfactory outcome...
Francois

altack
Posts: 33
Joined: Mon Nov 21, 2016 1:13 pm

Re: Strange potentiometer behaviour after AM 4.0 upgrade

#37 Post by altack » Sat Jun 12, 2021 1:37 pm

Problem is solved by updating AM to the 4.0.2 release.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest