Arduino connected but not working after V4 upgrade

Support for Arduino in combination with Air Manager and Air Player

Moderators: Ralph, russ

Message
Author
Mccluress
Posts: 10
Joined: Wed Apr 28, 2021 10:28 am

Re: Arduino connected but not working after V4 upgrade

#41 Post by Mccluress » Tue May 04, 2021 6:24 am

I hear you saying the binding messages mean nothing but my hardware connected to air player doesn’t work unless I wait to show the screen until after the arduino shows as connected.

User avatar
Corjan
Posts: 2368
Joined: Thu Nov 19, 2015 9:04 am

Re: Arduino connected but not working after V4 upgrade

#42 Post by Corjan » Tue May 04, 2021 7:53 am

Hi,

Yeah, that is because the fix I made for Air Manager is not yet pushed to Air Player applications.
I will push this fix to all applications once we have gathered a couple of fixes. Will probably release in about a month from now.

Corjan

old pilot guy
Posts: 12
Joined: Wed Dec 25, 2019 8:55 pm

Re: Arduino connected but not working after V4 upgrade

#43 Post by old pilot guy » Mon May 31, 2021 11:13 pm

Arduino mega 2560 (no clone) attached to pc running air manager connects in 15 sec.
Need to leave it this way for at least 2 minutes before running a custom panel or
testing the instruments in the "edit/create" tab. Otherwise binding fails. When Arduino
is connected to the pc running air player, it is also recognized in 15 sec / shows under the air player
device tab. Instruments imported to a panel created under the air player tab do not work. Same scripts/
instruments.
Air manager and air player versions 4.0.1 Both new custom pcs high end processors. Arduino connected
directly to usb 2.0- no hub. Seems to work better with 2.0 rather than 3.0
Any thoughts on why the Arduino won't work on the pc running air player? There is a second knobster
on the air player pc which works fine. Thanks

User avatar
Sling
Posts: 4431
Joined: Mon Sep 11, 2017 2:37 pm
Contact:

Re: Arduino connected but not working after V4 upgrade

#44 Post by Sling » Tue Jun 01, 2021 8:08 am

Have you flashed the Arduino with the latest AM build?

old pilot guy
Posts: 12
Joined: Wed Dec 25, 2019 8:55 pm

Re: Arduino connected but not working after V4 upgrade

#45 Post by old pilot guy » Tue Jun 01, 2021 6:40 pm

Yes. Multiple times. Is there a separate flashing for an Arduino to be used under air player as opposed to Air Manager ? I even have a second separate simulator running the same version of air manager with the same Arduino , works fine. Is there a special setting I need to use to make the Arduino run under air player? Since I used it to control the overhead zibo premium panel I run the panel of the instruments I created but do not display the Arduino panel. Also is it possible to run the create/ edit tab with a panel created under air player? These instruments are physical knobs and switches. I use the suggested lua scripts and not the pre-made hardware instruments.

Post Reply

Who is online

Users browsing this forum: No registered users and 8 guests