PI3 model b+ issues with hyperpixel 4

Support for Air Player on the Raspberry Pi.

Moderators: Ralph, russ

Post Reply
Message
Author
sirwio
Posts: 6
Joined: Sat Jun 19, 2021 1:08 pm

PI3 model b+ issues with hyperpixel 4

#1 Post by sirwio » Tue Jun 22, 2021 9:35 pm

In previous thread I described various issues with the Hyperpixel display and PI4's. Issue is that the PI4 does not support 90 and 270 rotations whilst the opengles drivers is loaded.... Pursuing that path is likely doable since my panels and instruments do show up on the display but in the wrong orientation since I want to mount the Hyperpixel in landscape orientation.

So I thought I would give one if my PI3's a chance. Its a model b+.

First issue is that the airplayer3 executable fails with siI2c warnings about fail to open device. Running the executable through strings I can see that it appears to reauire the /dev/i2c-1 device to exist. The hyperpixel 4 is using all i2c pins but pin 11. To work around that issue one can simply create a link from /dev/i2c-11 to /dev/i2c-1 as in:

Code: Select all

# sudo ln -s /dev/i2c-11 /dev/i2c-1
Adding the above softlink command to the /etc/rc.local finally brings up the airplayer3 executable when rebooted. But...

When a panel is "Shown" on the pi only the panel, with its chosen background, is rendered and not any instrument. I created a simple panel with a Cessna 172SP Callsign and the callsign won't show up!
This is what the log says:

Code: Select all

22-06-2021 22:00:21 INFO AirPlayer: Version 4.0.3 HOME_USE 
22-06-2021 22:00:21 INFO AirPlayer: HW id = 3052189a8e6d5742735f693f93de0a46
22-06-2021 22:00:21 INFO LicenseFile: Program version: HOME_USE, License: HOME_USE_FREE, Valid until: Unlimited
22-06-2021 22:00:21 INFO SimNavClient: Connected to 192.168.0.40
22-06-2021 22:00:21 INFO SimRemoteServer: Accepted connection from 192.168.0.40
22-06-2021 22:00:21 INFO SimBusConnectionHandler: Discovered X-plane on 192.168.0.40:55556 (am_port=55558)
22-06-2021 22:00:21 INFO Project: Aircraft changed from '(null)' to 'TBM 900 Published by X-Aviation'
22-06-2021 22:02:29 INFO LinuxTouchInputEvent: Bound to touch on /dev/input/event0
If the panel is hidden and shown again the only thing printed in the log is lines like:

Code: Select all

22-06-2021 22:05:32 INFO LinuxTouchInputEvent: Bound to touch on /dev/input/event0
22-06-2021 22:06:31 INFO LinuxTouchInputEvent: Bound to touch on /dev/input/event0
22-06-2021 22:06:37 INFO LinuxTouchInputEvent: Bound to touch on /dev/input/event0
22-06-2021 22:07:10 INFO LinuxTouchInputEvent: Bound to touch on /dev/input/event0
I would be grateful for some hints on howto troubleshoot this further.

-- Magnus

sirwio
Posts: 6
Joined: Sat Jun 19, 2021 1:08 pm

Re: PI3 model b+ issues with hyperpixel 4

#2 Post by sirwio » Wed Jun 23, 2021 10:57 am

The issue with instruments not rendered is most likely due to a not activated air player license. Thought I activated it but did obviously not follow the documented steps by first resetting existing license.

Meanwhile I have tested my setup with some opengles samples of rendering rotating cubes withe textures on the screen. Works perfectly fine with a fps of 61 and in landscape mode…

— Magnus

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests