Air player for RPi not loading in AM 4.02

Support for Air Player on the Raspberry Pi.

Moderators: Ralph, russ

Message
Author
Daguchan
Posts: 2
Joined: Fri Jun 11, 2021 4:15 pm

Air player for RPi not loading in AM 4.02

#1 Post by Daguchan » Fri Jun 11, 2021 4:29 pm

Hello,
After updating to AM 4.02 and lost the ability to connect to AP for RPi. All was working perfectly with the original version 4.0. I thought it might be a compatibility issue and that an Air Player update was also require. However, there doesn't seem to be an update for Air Player, Unfortunately, I selected the option to overwrite the original version of AM that was working. Is there somewhere where I can download AM 4.0? I wasn't having any issues with 4.0 and would like to revert.
Douglas

Daguchan
Posts: 2
Joined: Fri Jun 11, 2021 4:15 pm

Re: Air player for RPi not loading in AM 4.02

#2 Post by Daguchan » Fri Jun 11, 2021 5:36 pm

I found a copy of AM 4.0 but unfortunately now AP does not load in this version also. I have done nothing different and have rechecked all the procedures that I have been using up until updating AM. It would appear that the installation of the update may have changed something as everything was working up until this point. Both AM and AP are on the same network. Are there any checks that can be done to troubleshoot this type of issue?
Douglas

Richarsc
Posts: 10
Joined: Thu Nov 28, 2019 7:52 pm

Re: Air player for RPi not loading in AM 4.02

#3 Post by Richarsc » Sat Jun 12, 2021 3:49 pm

Hi

I have exact the same problem. I re-installed AP on the simcard, but it does not connect. I have connection with the RPI via PUTTY, so network is ok.
I tried to use the old version 3.7 AP, it connected, but told me it was the wrong version, and that is ok. But my Ver. 4.0 does not connect at all.

Regards
Richard Schumann

User avatar
Ralph
Posts: 5155
Joined: Tue Oct 27, 2015 7:02 pm
Location: De Steeg
Contact:

Re: Air player for RPi not loading in AM 4.02

#4 Post by Ralph » Sat Jun 12, 2021 3:59 pm

It's a bug in Air Player for Raspberry Pi. We'll probably have a new version this week.

Richarsc
Posts: 10
Joined: Thu Nov 28, 2019 7:52 pm

Re: Air player for RPi not loading in AM 4.02

#5 Post by Richarsc » Sat Jun 12, 2021 4:04 pm

Thanks Ralph for quick answer.

Will there be a notification when the bug-fix is ready to download?

Regards
Richard Schumann

mwaustin
Posts: 4
Joined: Sun Dec 06, 2020 4:24 pm

Re: Air player for RPi not loading in AM 4.02

#6 Post by mwaustin » Sat Jun 12, 2021 4:14 pm

Same exact problem here.

Air Manager 4.0.2 sees Air Player for RPi 3.7, but displays the mismatch message. Air Manager 4.0.2 does not see Air Player for RPi 4 (or to be explicit, it does not see the version of the Air Player for RPi 4 image that is currently linked via the wiki).

Likewise, I can also ssh into the pi that is running Air Player for RPi 4.

Just saw the reply - that this is a bug in Air Player for RPi 4 - that won't be fixed until next week. Wish it was a simpler fix as weekend plans are now disrupted - but appreciate the acknowledgement and update.

ReeceRobinson
Posts: 2
Joined: Sun Jun 13, 2021 6:28 am

Re: Air player for RPi not loading in AM 4.02

#7 Post by ReeceRobinson » Sun Jun 13, 2021 6:35 am

I just had this problem too. To work around it I logged on via ssh to the Pi and as sudo, manually started the AirPlayerPi3 application found under the home directory of the pi user. Once I started it, the Pi shows up in AirManager as a device again and I was able to click the light bulb icon next to my configured panel which then rendered on the pi display. Although this worked, the console shows lots of scrolling error messages.

Not sure if it was necessary but I changed the file permissions to add execute to the AirPlayerPi3 file.

Hope this helps while we wait for an official fix.

KrustyFM
Posts: 7
Joined: Sun Dec 17, 2017 11:14 am

Re: Air player for RPi not loading in AM 4.02

#8 Post by KrustyFM » Sun Jun 13, 2021 11:37 am

Hi guys,

have the same problem running AM 4.0.0 and 4.0.2.

Had no problem weeks ago after installing both AM and AP RPI new 4.x.x. versions, but now the RPI (3B+) just keeps showing the SimInnovations logo.
Updating AM to 4.0.2. makes no difference.

Versions 3.7 für AM und AP RPI did well before.

Looking forward to updates :).

Kind regards
MP

monkeysuncle
Posts: 34
Joined: Tue Nov 20, 2018 9:34 pm

Re: Air player for RPi not loading in AM 4.02

#9 Post by monkeysuncle » Sun Jun 13, 2021 1:00 pm

I have the same issue with my RPis, only the splash screen logo shows. I’m curious how this bug in the update to Air Manager would cause this, as the RPis are seeming independent from AM. When I power up my RPis without turning on my PC, the gauges appeared correctly. Then they didn’t.

Ralph, will there need to be an update to the RPi Air Player image as well as a fix to Air Manager?

User avatar
Corjan
Posts: 2422
Joined: Thu Nov 19, 2015 9:04 am

Re: Air player for RPi not loading in AM 4.02

#10 Post by Corjan » Sun Jun 13, 2021 6:33 pm

Hi,


I pushed a new Rpi binary last Friday. The Pi will automatically update the Air Player.
Clearly I made an error that causes the Air Player application to not start anymore. This Wednesday I will have a look why.

Once fixed, the Pi should again update to the fixed version (unless there is an issue with the bootloader, but that is unlikely).


Sorry for the inconvenience,

Corjan

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests