Search found 641 matches

by jph
Thu May 27, 2021 10:52 am
Forum: Air Manager Help
Topic: Raspberry PICO and Message Port ?
Replies: 8
Views: 382

Re: Raspberry PICO and Message Port ?

Corjan UPDATE- hmm. there does seem to be a small issue with baud rate selection where the pico seems to be ignoring the Serial.begin(XYZ...); Baud rate setting... :( - in the built in Arduino serial monitor, it doesnt matter what the baud rate is set to, it seems to be defaulting to somewhere at l...
by jph
Thu May 27, 2021 10:22 am
Forum: Air Manager Help
Topic: Raspberry PICO and Message Port ?
Replies: 8
Views: 382

Re: Raspberry PICO and Message Port ?

Hi, That issue has been fixed. It the Arduino library for the Pico mappes the Serial functions to the virtual serial port, it should work like any other arduino device. Not sure why it wouldn't, Corjan Corjan Hi Corjan Yes, it definitely maps to the VCP correctly. It compiles perfectly also. It is ...
by jph
Thu May 27, 2021 9:46 am
Forum: Arduino
Topic: SiMessagePort Won't Compile In Sketch
Replies: 37
Views: 1480

Re: SiMessagePort Won't Compile In Sketch

@Corjan

VERY much appreciated. It is really nice to be able to have the correct name applied to the device instead of using a generic one. I know they effectively all the same but it is still really good :D
Great work.
Joe
by jph
Wed May 26, 2021 9:05 am
Forum: Arduino
Topic: SiMessagePort Won't Compile In Sketch
Replies: 37
Views: 1480

Re: SiMessagePort Won't Compile In Sketch

Hi Gus,
I have submitted a support ticket for this.
Joe
by jph
Wed May 26, 2021 7:37 am
Forum: Arduino
Topic: Stepper 28BYJ loosing steps
Replies: 38
Views: 1953

Re: Stepper 28BYJ loosing steps

Will do that, Joe! But since yesterday, my Mega 2560 development board at my office desk has been in use for coding the interior lighting logic for our sim. ;) https://www.youtube.com/watch?v=HdQfAUjoYfU Nice ! :) you gained a subscriber as well :D I have re-wired the BYJ back to unipolar and am ju...
by jph
Tue May 25, 2021 12:30 pm
Forum: Air Manager Help
Topic: AM 4.0 Crashes on "Show" !!!
Replies: 33
Views: 1204

Re: AM 4.0 Crashes on "Show" !!!

Okay, the usual suspect. There's something wrong with Intel GPU's, we're not sure what. I'm also not sure if we can fix it, might be a problem in the Intel drivers. ;) Hey Ralph, That is a VERY VERY bold statement ... :o :) "There's something wrong with Intel GPU's " what ??? :shock: :shock: :shock...
by jph
Tue May 25, 2021 9:32 am
Forum: Air Manager Help
Topic: Raspberry PICO and Message Port ?
Replies: 8
Views: 382

Re: Raspberry PICO and Message Port ?

Just for information ..... I have always been under the impression that the 'naming' - as in - SI_MESSAGE_PORT_DEVICE_ARDUINO_LEONARDO is purely that - a name to refer to, as in, I just compiled the MP sketch on an UNO, but used the SI_MESSAGE_PORT_DEVICE_ARDUINO_LEONARDO in the messagePort = new Si...
by jph
Tue May 25, 2021 9:16 am
Forum: Air Manager Bug Reports
Topic: AM Not Detecting the Position Until an Update
Replies: 31
Views: 1310

Re: AM Not Detecting the Position Until an Update

Problem is, AFAIK there is not a message port() equivalent for the RAspi Pico in Air Manager. So how do you interface non supported hardware such as this screen in AM? Jacques PS: @jph Once again we are on a verge of polluting the thread of the OP about screens sinterfacing which is unrelated to th...
by jph
Tue May 25, 2021 8:59 am
Forum: Arduino
Topic: Wet Compass and Stepper Motor
Replies: 45
Views: 3848

Re: Wet Compass and Stepper Motor

Great implementation !!! I found it in "Add hardware instrument": To make it work properly with step motors from Amazon https://www.amazon.fr/Elegoo-Moteurs-28BYJ-48-Stepper-ULN2003/dp/B06XKRM1P1/ref=sr_1_5?__mk_fr_FR=%C3%85M%C3%85%C5%BD%C3%95%C3%91&crid=I6XCWW1P70JA&dchild=1&keywords=step+motor&qi...
by jph
Tue May 25, 2021 8:15 am
Forum: Arduino
Topic: Stepper 28BYJ loosing steps
Replies: 38
Views: 1953

Re: Stepper 28BYJ loosing steps

HI Marcel, Just to clarify, I am trying to determine if you are getting smooth action at slow speeds with just arduino code (without AM) I believe, from what you said, that it still appeared jerky (or jittering) at slow speeds with accelstepper ? I would like to check that out first as it shouldn't ...