Search found 17 matches

by Shimokuta
Tue Jul 06, 2021 2:50 pm
Forum: Arduino
Topic: API communication slow using messageport
Replies: 19
Views: 968

Re: API communication slow using messageport

hmm , i did not see any different behavious in speed with or without the messageport As soon as i change the font to a more larger font there is lag when turning the encoder. I suspect the I2C interface , but am not sure of course Here is my test script with font DSEG7_Classic_Regular_16 i am satisf...
by Shimokuta
Fri Jul 02, 2021 10:59 am
Forum: Arduino
Topic: API communication slow using messageport
Replies: 19
Views: 968

Re: API communication slow using messageport

Yes that is probably i good idea too.
I will write a test script to identify where the lag is comming from.
by Shimokuta
Wed Jun 30, 2021 7:29 pm
Forum: Arduino
Topic: API communication slow using messageport
Replies: 19
Views: 968

Re: API communication slow using messageport

i have to adjust my analysis.....
The smaller the font the smoother the interfacing runs.
When using a larger font there is lag again...also with the u8g2 library...
by Shimokuta
Wed Jun 30, 2021 5:52 pm
Forum: Arduino
Topic: API communication slow using messageport
Replies: 19
Views: 968

Re: API communication slow using messageport

Using the u8g2 library makes a huge difference!!!
When using this library instead of the AdaFruit, responses of turning the encoders are correct now.
by Shimokuta
Wed Jun 30, 2021 3:04 pm
Forum: Arduino
Topic: API communication slow using messageport
Replies: 19
Views: 968

Re: API communication slow using messageport

I am using a 1.54" I2C Oled display, similar to this one https://nl.aliexpress.com/item/1005002028967828.html?spm=a2g0s.9042311.0.0.27424c4djIxXgv I tried reducing the messageport ticks in my Arduino sketch, but this did even caused more latency!! So i increased the messageport ticks and this did sp...
by Shimokuta
Wed Jun 30, 2021 6:49 am
Forum: Arduino
Topic: API communication slow using messageport
Replies: 19
Views: 968

Re: API communication slow using messageport

Yes i have an I2C OLED interface.
I do update the display frequently, i was thinking this would perhaps speed up the interface.
hmm...i will go and try this.

Thanks guys!
by Shimokuta
Tue Jun 29, 2021 8:16 pm
Forum: Arduino
Topic: API communication slow using messageport
Replies: 19
Views: 968

API communication slow using messageport

I am using an arduino where a OLED screen is connected to display COM and NAV frequencies. I am using the message port to interface to AM 4.0 Also a dual encoder is connected to change the frequencies. This all is interfacing well, only it is very laggy.... When turning the encoder frequencies on th...
by Shimokuta
Mon Apr 26, 2021 9:37 pm
Forum: Air Manager Help
Topic: Arduino connected detection
Replies: 2
Views: 453

Re: Arduino connected detection

Yes i did.
I have found a fix.
I check the availability of a port of the arduino
ARDUINO_MEGA2650_B_D2

This solves the problem.
Still weird though.
by Shimokuta
Sat Apr 24, 2021 5:04 pm
Forum: Air Manager Help
Topic: Arduino connected detection
Replies: 2
Views: 453

Arduino connected detection

Hello I recently upgraded to AM 4.0. I build a little check in my LUA script to visualy show if an Arduino is connected or not If it is an image of an Arduino is shown , if not , the same image with a red cross is shown This script worked fine in 3.7 , but in 4.0 this detection doesn not work anymor...
by Shimokuta
Sun Mar 14, 2021 9:25 am
Forum: Lua and API Scripting Help
Topic: P3D Lights Eents and Variables
Replies: 1
Views: 588

Re: P3D Lights Eents and Variables

Same issue here...
did you ever solved this?