Search found 50 matches

by lonespace
Thu Jun 10, 2021 11:44 pm
Forum: Air Manager Help
Topic: x-plane dataref communication problem
Replies: 7
Views: 133

Re: x-plane dataref communication problem

As someone who basically only develops for Arduino and similar embedded types, it sometimes boggles my mind how careless some programmers can be with memory. A float for a switch position just seems so wasteful, but it’s actually pretty common from what I’ve seen
by lonespace
Thu Jun 10, 2021 6:28 pm
Forum: Air Manager Help
Topic: x-plane dataref communication problem
Replies: 7
Views: 133

Re: x-plane dataref communication problem

Might be a long shot but try subscribing to it as a float instead of an int
by lonespace
Mon Jun 07, 2021 7:14 pm
Forum: Air Manager Help
Topic: Panel not resizing smaller - Bell 407
Replies: 24
Views: 573

Re: Panel not resizing smaller - Bell 407

Avenger wrote:
Mon Jun 07, 2021 3:18 am
Can someone try it with the Bell 407 panel and a secondary monitor smaller than 1440p?
I’ve got a 407 setup with a 4K primary and a 1680x1050 for the panel and it works correctly for me
by lonespace
Mon May 31, 2021 11:03 pm
Forum: Under development and finished work
Topic: CowanSim 500E... MD369E gauges.
Replies: 1
Views: 113

Re: CowanSim 500E... MD369E gauges.

Wow those look great
by lonespace
Sun May 23, 2021 2:03 pm
Forum: Air Manager feedback & feature requests
Topic: Remote desktop
Replies: 9
Views: 738

Re: Remote desktop

Maybe Synergy would work for you?
https://symless.com/synergy
by lonespace
Sun May 16, 2021 6:15 pm
Forum: General Discussion on Anything
Topic: Forum regularly spammed
Replies: 46
Views: 5579

Re: Forum regularly spammed

Is there anything way to filter posts based on such forbidden words?
by lonespace
Sun May 16, 2021 5:05 pm
Forum: General Discussion on Anything
Topic: Forum regularly spammed
Replies: 46
Views: 5579

Re: Forum regularly spammed

What mechanism is putting “*spam*” in the title? Is it some automated forum mechanism or the bots themselves?
by lonespace
Sat May 08, 2021 4:16 am
Forum: Arduino
Topic: messagePort->SendMessage not functioning
Replies: 2
Views: 245

Re: messagePort->SendMessage not functioning

That worked, thanks.

Seems pretty obvious in hindsight, as these often do
by lonespace
Sat May 08, 2021 2:47 am
Forum: Arduino
Topic: messagePort->SendMessage not functioning
Replies: 2
Views: 245

messagePort->SendMessage not functioning

Arduino: Pro Micro clone Air Manager version: 3.7.10 OS: Windows 10.0.19042 I currently have the same hardware working through messagePort, but I'm only sending data from the instrument to the arduino (code here , if you're interested). However, if I try to send data back to the instrument, it never...
by lonespace
Sun Apr 18, 2021 7:45 pm
Forum: Lua and API Scripting Help
Topic: SI message port: WIKI error?
Replies: 24
Views: 1725

Re: SI message port: WIKI error?

I’m able to use i2c with the message port, and I can’t see how the message port would interfere with any SPI implementation. Try to create the simplest possible test script that implements both to see if the conflict lies somewhere else in your code.